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CAM350 为 PCB 设计和 PCB 生产提供了相应的工具（CAM350 for PCB Designers 和 CAM350 for CAM 
Engineers），很容易地把 PCB设计和 PCB生产融合起来。 
 
CAM350 v8.7的目标是在 PCB设计和 PCB制造之间架起一座桥梁 随着如今电子产品的朝着小体积、高速度、低
价格的趋势发展，导致了设计越来越复杂，这就要求精确地把设计数据转换到 PCB生产加工中去。 CAM350为您提供了

从 PCB设计到生产制程的完整流程，从 PCB设计数据到成功的 PCB生产的转化将变得高效和简化。 基于 PCB制造过程，

CAM350为 PCB设计和 PCB生产提供了相应的工具（CAM350 for PCB Designers和 CAM350 for CAM Engineers），很容

易地把 PCB设计和 PCB生产融合起来。   平滑流畅地转换完整的工程设计意图到 PCB生产中 

  提高 PCB设计的可生产性，成就成功的电子产品 

  为 PCB设计和制造双方提供有价值的桥梁作用 CAM350是一款独特、功能强大、健全的电子工业应用软件。DOWNSTREAM

开发了最初的基于 PCB设计平台的 CAM350，到基于整个生产过程的 CAM350并且持续下去。CAM350功能强大，应用广泛，

一直以来它的信誉和性能都是无与伦比的。 CAM350  

PCB设计的可制造性分析和优化工具 
 
今天的 PCB 设计和制造人员始终处于一种强大的压力之下，他们需要面对业界不断缩短将产品推向市场的时间、品质

和成本开销的问题。在 48 小时，甚至在 24 小时内完成工作更是很平常的事，而产品的复杂程度却在日益增加，产品

的生命周期也越来越短，因此，设计人员和制造人员之间协同有效工作的压力也随之越来越大！ 
 
随着电子设备的越来越小、越来越复杂，使得致力于电子产品开发每一个人员都需要解决批量生产的问题。如果到了完

成制造之后发现设计失败了，则你将错过推向市场的大好时间。所有的责任并不在于制造加工人员，而是这个项目的全

体人员。  

 
多年的实践已经证明了，你需要清楚地了解到有关制造加工方面的需求是什么，有什么方面的限制，在 PCB设计阶段或

之后的处理过程是什么。为了在制造加工阶段能够协同工作，你需要在设计和制造之间建立一个有机的联系桥梁。你应

该始终保持清醒的头脑，记住从一开始，你的设计就应该是容易制造并能够取得成功的。 

 

CAM350 在设计领域是一个物有所值的制造分析工具。CAM350 能够满足你在制造加工方面的需求，如果你是一个设

计人员，你能够建立你的设计，将任务完成后提交给产品开发过程中的下一步工序。现在采用 CAM350，你能够处理

面向制造方面的一些问题，进行一些简单地处理，但是对于 PCB设计来说是非常有效的，这就被成为 "可制造性

(Manufacturable)"。   
可制造性设计(Designing for Fabrication) 
使用 DFF Audit，你能够确保你的设计中不会包含任何制造规则方面的冲突(Manufacturing Rule Violations)。DFF 

Audit 将执行超过 80 种裸板分析检查，包括制造、丝印、电源和地、信号层、钻孔、阻焊等等。建立一种全新的具有

艺术特征的 Latium 结构，运行 DFF Audit 仅仅需要几分钟的时间，并具有很高的精度。  

 
在提交 PCB去加工制造之间，就能够定位、标识并立刻修改所有的冲突，而不是在 PCB板制造加工之后。DFF Audit 将

自动地检查酸角(acid traps)、阻焊条(soldermask slivers)、铜条(copper slivers)、残缺热焊盘(starved thermals)、

焊锡搭桥(soldermask coverage)等等。它将能够确保阻焊数据的产生是根据一定安全间距，确保没有潜在的焊锡搭

桥的条件、解决酸角(Acid Traps)的问题，避免在任何制造车间的 CAM部门产生加工瓶颈。  
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分析的结果将图形化的方式显示在图中，很容易观察  

冲突能够立刻观察到，并且潜在可能的问题立刻得以修复  

直接使用正确的数据更新你的数据库，确保所有内容的完整性和一致性 在设计期间进行 DFF 分析将使你能够始终对

数据进行控制或改变。现在制造加工人员必须处理你的设计文件，以便能够加工出裸板。所以，如果制造人员检测到有

酸角(acid trap)存在，他们将简单地贴一块铜到这个缝隙中，其实，也许你原理重新布线，则可以消除产生酸角 
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CAM350 为 PCB 设计和 PCB 生产提供了相应的工具（CAM350 for PCB Designers 和 CAM350 for CAM 
Engineers），很容易地把 PCB设计和 PCB生产融合起来。 

 
(acid trap)的可能。如果这样的话，你的设计数据并不需要更新，其结果是你纳杓频耐暾□缘玫搅吮ＶぁＨ绻□阒匦赂

谋淞四愕纳杓疲□庑┬碌陌姹窘□岣哺窃□吹挠形侍獾陌遄印?lt;/FONT>  

 
这就是说，你的设计能够满足制造人员的需要，而一些都是你完成的，你提交该他们的是具有很高品质、可制造的设计

文件。这将节约了制造加工的时间、反复和经费开销，你的产品更快地推向市场才有可能。   
设计规则检查(Design Rule Checking) 
CAM350 还具有检测各种各样类型空间距离冲突的功能，例如，导线到导线、导线到焊盘、焊盘到焊盘、是否有钻孔

但是没有焊盘、有焊盘没有钻孔等等。另外，DRC 还能够进行各种比较。例如钻孔对阻焊、阻焊对焊盘、钻孔对焊盘

检查中间环的问题等，作为附加的一项功能，你还能够预先定义多次重复工作，以检查不同的层，使用不同的规则等，

然后将它们作为一个批处理方式进行工作。这将避免了你需要重复运行 DRC，它在中间层或外层上允许有不同的空间

间距规则。 
 
在使用 DRC 浏榄器查看已经标识具有冲突的期间，有一个信息框将出现，为你显示有关你当前查看的冲突的详细信息，

这将加速查看处理过程，避免需要使用附加的查询命令，详细的信息就在你的眼前。 
 
如果你不运行 DRC，你应该自己清楚这些空间间距冲突，因为它们会在制造过程中出现问题  

建立在具有艺术性的 Latium 结构中，DRC 具有特别强大的功能和性能优越的特点   
数据输入和输出 
CAM350 是一个灵活的、开放的系统，它提供了范围广泛的输入和输出能力，包括 ODB++、Gerber、DirectCAM、

IPC D- 356 和许多其它的格式。CAM350 还具有输入高级 CAD数据格式的选项，包括 PowerPCB 和 Boardstation

等等。  

 
通过使用这些具有智能化的数据格式，CAM350 能够扩展它支持的内部孔径(aperture)形状的数量。现在，有一些并

不需要定义为 "Custom" 孔径(apertures)了。它们中的有一些可能是具有圆角的矩形、具有斜面的矩形、方形的热焊

盘、椭圆形、子弹形(bullet) (或 D- 形)。   
DirectCAD 技术 
我们定义我们的接口界面具有智能的 CAD数据库，即 DirectCAD。通过使用这个功能，你将能够提供你的制造工具具

有真实的设计数据，这样，你的制造人员就能够采用这种级别的信息数据进行工作，你将会从这种精确的设计转换之间

得到益处。  

 
CAM350的 DirectCAD 技术读取或写入的是智能化的 CAD 数据，它自动地捕获设计的各种属性，收集各种制造数据，

所以，你不再需要面对那些并不友善、不十分清晰的 Gerber 文件了。其结果是更少地绘制数据、得到一个好的网表、

更少需要解决制造工具的问题。设计人员的智能将用于制造，以及制造加工的全过程。  
反向工程(Reverse Engineering) 
如果你现在有一些以前留下来的 Gerber 格式数据，或者是以其它 CAD格式保留的数据，CAM350 能够让憬□?"反
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向工程(reverse engineer)"。这个功能将允许你将这些老的设计数据保存为当前你正在工作的格式的数据。只需要简

单的几步，你将能够将这些文件进行反向工程转换到你选择的 CAD系统。  
绘图到光栅的多边形转换(Draw-to-Raster Polygon Conversion) 
Draw-to-Raster Polygon Conversion 对于优化数据来说已经变成非常重要的部分，Draw-to-Raster 转换将使你

减少你的数据大小尺寸，它是通过转换大量的 "矢量(vector)"填充的灌铜到数据更小的 "光栅(raster)"文件。这些光

栅文件则能够被光绘机计算处理，这就避免了需要保存许多类似"外框(Outline)"这样的数据在 Gerber 数据中。现在

建立在高级的 Latium 结构中，这个处理时间被大大地减少了。  
 

电子软件及 PCB软件专题-CAM350专题 
-CAM350 8.0 文件菜单(File) 

-CAM350 8.0 添加菜单(Add) 

-CAM350 8.0 查看菜单(View) 

-CAM350 8.0 信息菜单(info) 

-CAM350 8.0 转换菜单(Utilities) 

-CAM350 8.0 分析菜单(Analysis) 

-CAM350 8.0 工具菜单(Tools) 

CAM350 技巧之四 

-改变 CAM350有关设置 
-CAM350 8.0 图表菜单(Tables) 

-CAM350 8.0 其它菜单 

-CAM350 NC 编辑器编辑菜单(Edit) 

-CAM350 NC 编辑器其它菜单 

-制作锣带的基本步骤 

-CAM 350筛选编辑器 

-CAM 350一些基本操作 

-CAM350 V8.0 用户界面介绍 

-CAM350 中资料的读入 

-CAM350猜格式技巧 

-CAM350 读入文件出错分析 

-CAM350 基本操作 

-CAM350层的编辑 

-改变 CAM350有关设置 

 

 

CAM350 8.0 文件菜单(File) 
1. new ：新建（快捷键 Ctrl+N）。 

 

2. open：打开（快捷键 Ctrl+O）。 

 

3. save：保存（快捷键 Ctrl+S）。 

 

4. save as：另存为。 

 

5. merge：合并两 PCB 文件。可将两层排列方式基本一致的板做拼接，若掌握熟练可拼接文件用于菲林绘制。 
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6. Import：导入文件。 

 

Autoimport：自动导入文件。 

系统自动为选择的文件做光圈表匹配，若有匹配不正确或无法匹配的则可做调整，选择其他光圈编译器或重新编辑编译器并做检查。 

 

Gerber data：导入 Gerber 文件。对于 RS274-X 文件自带 D 码即可将文件调入，而对于 RS274-D 文件则通过调整文件格式来调试到

显示正确的图形。 

 

Drill data：导入钻孔数据。同样通过格式调整来调试图形正确性。 

 

Mill data：导入铣边资料。 

 

Dxf：一种文件格式，一般有客户提供此类文件作为说明。 

 

Aperture table：光圈表。 

当确定光绘文件调入正确，而光圈表不匹配的情况可使用该指令来调整光圈表使用的编译器。 

 

7. Export：导出文件。 

Composites：复合层输出。 

Drill data：钻孔数据。 

Mill data：铣边数据。 

 

8. Print：文件打印。 

Setup printer：打印机设置。 

Print display：打印预览。 

 

9. Setup：系统设置。 

 

Preferences：参书选择。 

可设置优先缓存区，如：undo 恢复键功能；自动备份的功能，但常规下不做自动备份。 

 

Paths：路径。定义系统显示的输入输出及其它一些环境文件所在的默认路径。 

 

File extensions：设置输入输出文件扩展名的默认值。 

 

Colors：设置显示的颜色。可根据个性进行设置。 

 

Photoplotter：对光绘程序中指令的识别进行设置。 

 

有客户设计软件生成的文件在该选择不同时将会有不同识别程度，不要轻易更改其间参数。当发现文件中有不明设计的圆弧，可通过

选择 Ignore arcs with same start/cnd points 调试后与客户确认，或发现文件中焊盘线处于未填实的情况可通过将 Interpolated arc if no 

G74/G75 由 Quadran 调至 360 Degrees，切记当调试后再做其他板之前请务必调回原默认状态。 

 

Nc-mill machine：为铣边文件设置默认格式。 

 

Nc-drill machine：为钻孔文件设置默认格式。 
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Save defaults：将当前环境设置为默认环境。在每次使用 New 指令即可进入该默认环境。 

 

10. Exit：退出。 

CAM350 8.0 添加菜单(Add) 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:27 

 
1. Flash：增加焊盘。 
 
2. Line：增加线。 
 
3. Polygon：增加多边形或铜皮。 
 
铜皮有非矢量（Raster）和矢量（Vector）两种，可设置填充铜皮与边框线的距离。注意用于填充的边框必须为封闭。 
 
4.Polygon Void：截除填充部分。 
 
Line：线 
Circle：圆 
 
5. Text：增加字符，可以在任意一层上添加文字说明。 
 
Style 按钮是用来设置文本的字体、大小、对齐方式、字间距的。在 D 码列表中选择合适的 D 码，在层列表中选择
文本所在的层。字符设置也可在 Text Style 中进行。 
 
6. Rectangle：增加方框。 
 
7. Circle：增加圆。 
 
Center-Radius：中点-半径 
3-Points：3 点 
 
8. Arc：增加弧。 
 
Center-Angle：中点-起点 
3-Points：3 点 
2-Points：2 点 

 

CAM350 8.0 查看菜单(View) 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:26 

1. Window：窗口放大查看（快捷键 W）。 
 
W 键可与许多操作指令配合使用，可做窗口内和窗口外的选择（快捷键 I），也可做选择某元素部分或全部的切换（快
捷键 C）。 
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2. All：查看整个图形（快捷键 Home）。 
 
3. Redraw：刷新（快捷键 R）。 
 
4. In：放大（快捷键 +）。 
 
5. Out：缩小（快捷键 -）。 
 
6. Pan：平移显示（快捷键 Insert）。此项操作用于逐屏检查，注意技巧。 
 
7. Composite：合成。 
 
8. Back side：反面。 
 
9. Rotate：旋转。 
 
10. Tool bar：显示工具条。 
 
11. Status bar：显示状态栏。 
 
12. Layer bar：显示图层条。 

CAM350 8.0 信息菜单(info) 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:26 

1. Query 查询图形属性 
 
All：显示当前元素的所有信息（快捷键 Q）。 
 
Net：显示当前网络的所有信息。 
 
Dcode：显示当前 D 码的所有信息。 
 
2. Find：查找。 
 
3. Measure 测量距离 
 
Point to point：测量点到点的距离。左上角的 L0、L45、L90 表示其角度。 
 
Object to object：测量两元素间的距离。 
 
4. Report 报告 
 
Dcode：显示所有层或指定层的 D 码表。 
 
Nc Tool：显示钻孔报告。 
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CAM350 8.0 转换菜单(Utilities)----  
来源:网上收集   作者:未知   日期:2005-11-19 10:51:12 
1. Draw to custom：线转自定义 D 码。 

 

Draw To Symbol：画线转符号（排版时用）。 

 

2. Draw to flash：可将某些线转换成焊盘。 

 

Automatic：自动 

 

Interactive：交叉 

 

3. Polygon conversion：多边形转换。 

 

Draw To Raster Poly：线转换成光栅。 

 

Raster Poly To Vector Poly：光栅转换成矢量。 

 

Draw To One-Up Border：定义单元 Border。 

 

4. Draw To raster poly：将非矢量的区域转换成矢量。 

 

5. Netlist extract：生成网络。 

 

Clear Silkscreen：清除丝网标记。 

 

6. Data optimization：数据优化。 

 

Remove isolated pads：删除孤立焊盘。使用该指令时要注意其是否会造成断线开路。 

 

Remove redundant pads：删除重叠的焊盘。 

 

7. Teardrop：泪滴型焊盘。为了增加焊盘和线路的接触面积以降低因开路造成的报废。 

 

8. Over/under size：统一放大/缩小各元素的尺寸。会重新产生新 D 码，并不会改动图形的尺寸比例。 

 

9. Panelization：排版编辑器。 

 

10. Convert Composite：转换复合层。 

 

11. Composite To Layer：复合层合到层。 

 

CAM350 读入文件出错分析 

文件的扩展名不同，只是输出底片文件的 CAD 软件不同罢了，其实质是一样的，都是 Gerber File。 
 
可能造成我们输入错误的因素有： 
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a) 输入 gerber file 时的单位选错 (Metric or English)。 
b) 如果 gerber file 是 RS-274 格式的，读错其配套的 aperture 文件 （最可能）。 
c) 软件本身的 bug 
 
下面，就对 a 和 b 进行说明： 
 
a) 一般来说，gerber file 都是英制的，因为大多数 CAD 软件为西方国家的产品。 
 
如果使用 CAM350 的 AutoImport 功能输入 RS-274X 格式的 gerber file，操作如下： 
 
1. 选择 File -> Import -> AutoImport 选项。 
 
2. 在对话框中，选择 gerber file 放置的文件夹，点选 gerber file 是公制还是英制（English or Metric），按 Finish 完
成。 
 
3. 需要注意，要输入的所有 gerber file 必须放在同一文件夹中，不能同时有不相关文件在这一文件夹中，才能正
确读取这一文件夹中的 gerber file。 
 
b) 标准的 gerber file 格式可分为 RS-274 与 RS-274X 两种，其不同在于： 
 
RS-274 格式的 gerber file 与 aperture 是分开的不同文件。 
 
RS-274X 格式的 aperture 是整合在 gerber file 中的，因此不需要 aperture文件。 
 
(Gerber file 的格式：通常，英制是 2.4 格式，公制是 3.3 格式)为了读对 RS-274 格式的 gerber file，你需要有如下
概念：RS-274 格式的 gerber file 必须同其对应的 aperture 文件配合才能正确输入。 
 
CAM350 的 AutoImport 功能读 RS-274 格式的 gerber file 是能自动辨认 aperture 的格式的（不同的 CAD 软件产
生的 aperture 的格式也是不同的），而 CAM350 的这一功能又是靠其安装目录中.arl 为模板来实现的。 
 
当我们用 CAM350 不能正确读入 RS-274 格式的 gerber file 时，通常是因为不能正确辨认 aperture 而造成的，这
就需要编写自己的.arl 文件来协助 CAM350正确读入 gerber file。 
 
辨认 aperture 读入正确与否的方法： 
 
看 aperture table 是否均已正确读入，不存在 undefined aperture。如果线路层（copper layer）中有 QFP 的话，看其
方向是否对。这种情况通常是 rectangle 的 aperture 被读反而造成的（X, Y 读颠倒）。 
 
其它明显的不正常现象，如：线端无 pad、不合理断、短路等。 
 
当你读入 RS-274 格式 gerber file 发现外形尺寸正确，而线路、pad 明显偏小或偏大，这通常是 CAM350 的.arl 文
件单位设置与读入的 aperture 单位不符造成的。正确读入做法如下： 
 
使用 AutoImport 功能，点击 Next 与 Scan each Gerber 选项。 
 
在出现的对话框中，察看 CAM350 读入时所用的.arl 模板名是什么。 
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找到此.arl 文件，修改其单位，另存为改名的.arl 文件。 
 
*.arl 文件的文件名通常与.arl 模板名类似，上例的.arl 文件的文件名为：pcad8.arl（CAM350 自带的标准.arl 文件）。 
 
如果线宽、pad 大小正确，而外形明显偏大时，会看起来线路过于稀疏，这是因为 gerber file 的单位选错（公制
选成英制）。 

CAM350 8.0 分析菜单(Analysis) 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:23 

1. Analysis：对于与电性能的相关检测先生成网络再制作。 
 
2. Acid traps：分析查找弯角距离太小或角度小于要求值的铜线。 
 
3. Copper slivers：文件中的残铜。 
 
4. Mask slivers：文件中的阻焊碎片。 
 
5. Find solder bridges：检测阻焊桥。 
 
6. Find starved thermals：测试热焊盘的开口宽度。 
 
7. Silk to solder spacing：检测丝印至线路的间距。 
 
8. Drc：设计规范检查。 
 
该指令在检测中使用较多，主要可作为线距、盘距、线距盘、各焊盘外径及空盘相对应等检测项目，以支持 CAM 的
主要工作。 
 
9. Check Net：网络测试。 
 
主要用于针对当前图形与原生成的网络做开路检测，即两层不在同一网络的 plane 层不同时为热焊盘确保不短路。 
 
10. Copper area：铜皮面积。 
 
11. Compare layers：层比较。用于文件自检。 
 
12. Check mill：检测铣边。检测外形补偿与实际宽度或弧度是否有冲突。 
 
13. Check dirll：检测钻孔。检测有无重孔、叠孔、孔距离 

 

CAM350 8.0 工具菜单(Tools) ---  
来源:网上收集   作者:未知   日期:2005-11-19 10:50:48 
1. CAM Editors：默认的编辑器。用来导入和输出数据。还包括 DRC、拼版及其他制造预备步骤。 

 

2. CAP Editors：光栅编辑器。作用：建立或修改一个自定义 D 码。后缀为：CLB 
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3. Part Editors：零件编辑器。作用：建立或修改一个新的零件。后缀为：PLB 

 

4. Flying Probe Editors：飞针测试编辑器。 

 

5. Bed Of Nails Editors：针床编辑器，即电脑测试架。 

 

6. NC Editors：数控钻、铣编辑器，即 CNC 数据。用于 NC 程序的制作生成。 
 

CAM350 技巧之四 

 
1. 问：怎么在 CAM350 中如何添加文字？ 
答：Add -> Text ,添加文字时要指定圆形 d 码，直接选择一个 round d 码，不要太大。也可以在 CAM350 中按 A 呼
出光圈表，选择或自定义圆型 D 码! 
 
2. 问：CAM350 中可以加英文、数字和汉字吗？用 CAD 转过来的好像线变形了，有办法让字体不变形吗？ 
答：可以在 cam350 中加英文和数字，用 add -> text 命令。如果是 cad 文件的字体，你可以在 cad 软件中把 cad 的
字体打散，用填充命令填充一下就可以了。 
 
3. 问：如何在 CAM350 里面添加中文字？ 
答：a.cam350 不支持中文，你可在 autocad 中加好再导入 cam350 中。AutoCAD中可以转出 DXF 和 HPGL 文件，
DXF 虽然在 CAM350 中装入会变形，不过如果你在装入时选好字体，也是可以的。而转成 HPGL，再填充也可以。 
b.用 PROTEL 加完字再导出 GER 文件。 
c.用 UCAM 转入。 
 
4. 问：如何将各种图案 LOGO 加入到 PCB 的丝印层中，要用到什么工具软件？ 
答：如果你的 Logo 已经是 Gerber 文件，可以直接读入 CAM350，然后复制到丝印层就行了；如果是 BMP 文件
可以用先 BMP2PCB 软件，然后再用 Protel 读入转成 Gerber 就成了；如果是 AutoCAD 格式的文件，可以用
AutoCAD 转成 DXF 格式再用 CAM350读入就行了。 
 
5. 问：在 V2001 里设定负片很容易，而且画出的线可设定看不到，可在 Cam350里面是不是一定要做一个复合层
才行，还是直接建一个新层设定为负层？ 
答：可以先画好，再 Tables -> Composites 设定成复合层。 
 
6. 问：怎样在 CAM350 V8.0 中输出负片，如我 LAYER1 是线路，LAYER2 是档油 PAD，我想在 CAM 中把这两
层合在一起出一张负片菲林，怎样才能把它们两层叠加在一起呢？ 
答：在 cam350 中建立一个复合层 Table -> Composites ---add，输入叠加层并指定属性即可。 
 
7. 问：怎样把 CAM350 层文件复合成一个文件，再打开就一文件？ 
答：直接用 Utilities -> Convert composite 或 Composite to layer 就可以了。 
 
8. 问：如何实现 CAM350V7.5.2 里的 PCB 文件分层打印？ 
答：在打印对话框下不是有一项 separate sheets，选中它就可以分层打印了。 
 
9. 问：在 CAM350 中怎样把两款不同产品的 Gerber 文件拼到一张图中？ 
答：a. File -> Merge，合并两 pcb 文件。 
b. 直接将需要拼到一层的两个 Gerber 移动或者复制到同一层就行了。 
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10. 问：CAM350 可以自已编一些更实用的 scirpt，不知道是不是？ 
答：macro 下的 record 自动记录过程式，形成宏程式。 
 
11. 问：在 CAM350 中怎样选点？ 
答：Tools -> Bed of Nails Editor,这是制作测试架的模块，在这之前你得先定义好层的属性，用 Utilities > Netlist Extract 
提取好网络，才能制作测试架。 
 

改变 CAM350有关设置 

来源:网上收集   作者:未知   日期:2005-11-19 10:51:11 
和其他软件一样，CAM350 也可以更改有关设置，如改变单位、字体、宏设置等。这里就简单介绍提到的这三种
设置： 
 
1.单位：利用 Settings -> Units 菜单可以改变单位的设置。提供选择的有英制(English-mils)、公制(Metric-mm)两
种。此外对每一种单位都提供 5 种由低到高的精确度选择。 
 
2.字体：利用 Settings -> Text 可以打开“Text Style”对话框。在这个对话框中可以设置不同字体、字高、字间距、
对齐方式等参数。点击“Font”按钮打开“Font List”字体选择列表，选择理想的字体。在下方的框中会出现相应
的该字体的模板，然后 OK。字符和线的间距在“Spacing”中设置：垂直/水平方向的对齐方式在“Justification”
中分别进行设置。 
 
3.宏命令设置（Macro）：那些能自动执行某种操作的命令统称为“宏”。宏也是一种操作命令。它和菜单操作命
令都是一样的，只是他们对数据库施加作用的时间有所不同。作用时调节也有所不同。菜单命令一般用在数据库的

设计过程中， 
而宏命令则用在数据库的执行过程中。菜单命令必须由使用者来施加这个操作，而宏命令则可以在数据库中自动执

行。CAM350 中也集成了宏命令极其相关的操作。 
 
对于频繁使用到的菜单项，可以利用这一功能快速的执行。如 File -> Save等常用的命令都可以直接用热键打开。
这一功能的实现是在 Macro -> Assign ->Function Keys 菜单下，点击就会弹出“Function Keys Assignment”对
话框。 
 
如果把热键和组合键加在一起，CAM350 能提供 48 种快速打开菜单命令项的选择。每个热键按钮的最右变有一
“DEL”按钮，可以用来删除已设置的菜单项。 

CAM350 8.0 图表菜单(Tables)----- 

1. Apertures：光圈表。包括多种类型，含 custom（自定义）型。 
 
Next Undefined：跳转到下一个尚未定义的 D 码。 
 
Compress：将已定义的 D 码排在一起。 
 
Go To Custom：跳转到输入的 D 码。 
 
新建一个 D 码： 
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在左边选择一个空的 D 码号，然后在右边的 Shape 中选择一个 D 码的形状，最后输入其数值即可建立起一个新的 D 码供使用了。 
 
如：建立一个 Round，然后在 Diameter 中输入这个圆的直径就可以了。 
 
删除 D 码：Edit->Delete 移动光标选择要删除的元素即可完成。 
 
改变 D 码：进入 Aperture Definition，选择新的 D 码形状替代当前正使用的 D码形状就行了。 
 
Custom：（自定义 D 码） 
 
建立自定义 D 码：在 Tools -> Cap Editor 中直接创建自定义光圈，这些自定义 D 码形状包括：散热盘、三角形、钻石形、斜角长
方形、异形、子弹形、多边形或任何你所需要到所想要的图形，最后保存即可。在 D 码表中，通过改变 D 码类型来替代你所想改变
或替代的 D 码形状，这是非常方面实用的。 
 
2. Padstacks：焊盘堆（生成网络时会将同一孔位的所有焊盘组成一焊盘堆）。 
 
3. Layers：层属性表。定义每层的属性为自动拼板和生成网络的前提条件（快捷键 Y）。 
 
4. Composites：复合层定义。Dark（正片）、clear（负片）。 
 
5. Layers mapping：层的映射表。 
 
6. Nc tool tables：钻孔刀具表。 

 

CAM350 8.0 其它菜单 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:22 
宏菜单 -- Macro: 
 
1. marco：宏指令。要求有一定的编程能力制作。 
 
2. 自定义快捷键：在菜单栏空白处，单击鼠标右键，点 customize 进入。选择 keyboard 选项,在 Category 里选择
命令所在的菜单，在 Commands 里选择命令,在 Press New Shortcut 里输入你所要定义的键，点击 Assign 完成。可
设置任意键。 
 
设置菜单 -- Setting： 
 
1. Unit：设置单位和精确度（小数位数）。 
 
2. Text：设置字体属性。 
 
3. View options：设置查看选项。 
 
4. Arc/circle 设置弧/圆的默认值。  
 
帮助菜单 -- Help： 
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1. Hot Keys 调用的是 camnt95.chm 文件，可以自己做个 CHM 的文件覆盖它。 
 
2. What's New 调用的是 read.me 文件，可以用记事本打开，编辑自定义内容。比如说编辑快捷键列表或者一些使
用技巧，这样在需要的时候就可以很方便的打开看了。  
 

CAM350 NC 编辑器编辑菜单(Edit)------ 
来源:网上收集   作者:未知   日期:2005-11-19 10:50:56 

 

编辑菜单之一： 

 

1.undo： 撤消。也就是返回上一步（快捷键 U）。 

 

2.redo： 恢复。如果你 undo 用错了，就可以用 redo 恢复（快捷键 Ctrl U）。 

 

3.Move： 移动。 

 

选择 MOVE 命令后，再按 A 是全选，按 I 是反选，按 W 是框选（按 W 就是要用鼠标把整个元素都框上才能选中），按 C 的效

果很特别（按 C 只要选中该元素的一小部分就能选上，）什么都不按的话就是单元素选择。 

这里对操作界面进行具体介绍： 

 

左上角的“数字：数字”：就是栅格的间距，可自己设置比例（按 V 就可显示栅格，按 S 就是光标随删格移动）。 

“L 数字”：设置角度，有 0，45 和 90 可以选择（快捷键 O）。 

“Move To Layer”：移动到其它层。选择你要移动到的层，可以是一层，也可是多层。 

 

紧跟着的就是筛选元素的类型，有 drw，flsh，drill，mill 等（不同的命令有不同的类型可选择，有时还会有 VIA 等选项）。 

 

“Filter”：筛选元素。 

 

Ddoces：筛选 D 码。填上你所要 D 码的号数，两个以上用逗号隔开。 

0 或空白 = 全选 

#，#，…… 包含 

#：#，…… 范围 

-#，-#：#，…… 不包含 

Tool References：筛选钻孔。 

Polygon Filter：多边形过滤。 

Text Filter：文字过滤。 

 

"Prev"：功能跟按W 的效果差不多，也是框选，但它有一个特性，就是可以记住上一次曾经选过的东东，请活用这功能！ 

“SelectAll”：跟按 A 的全完一样，也就是全选啦。 

 

右下角那“数字：数字”就是 X,Y 的坐标系数（可更改），这是一个能令操作精度变得更高的命令，请多加运用。双击后出现一个小

界面框，旁边的“Abs”是绝对坐标，“Rel”是相对坐标。“Abs”是指以 origin 为基准，“Rel”则是以你在主画面中最后一次鼠标左键操

作为基准。 

 

坐标系数的右边显示的是单位MM 或MILS，更改单位在“Settings”菜单里。 

 

4.Copy： 复制。Copies：这里填上你要复制的倍数，To Layers：选择你要复制到的层，可以是一层，也可是多层。 
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5.Delete：删除。 

 

6.Rotate：旋转。有几种角度可以选择，也可以自定义旋转角度。 

 

7.Mirror：镜像。Vertical 是 X 轴镜像，再按一下就变成 Horizontal 是 Y 轴镜像。 

 

编辑菜单之二：  

 

1. Layers（层操作）：每一个 PCB 板基本上都是由线路层、阻焊层、字符层、钻孔数据层、DRILL 层所组成的，在 CAM350 中，

每载入一层都会以不同的颜色分别开，CAM350 提供了强大的层处理功能。如：层对齐、增加层、层排序、层 

删除、层缩放等。 

 

Add layers：增加层，在左边工具条有快捷按钮。 

 

Remove：删除层。按 Compress 可自动识别无用层。 

 

Reorder：重新排列层。可通过鼠标来调整，然后点 Renumrer 重新排列层号。 

 

Allign：定位。用于层与层之间的对齐。 

 

Snap pad to drill：将焊盘与焊盘对中。可选择 Tolerance 即在坐标相差多少之内的可做对中移动。 

 

Snap pad to drill：将焊盘向钻孔对中。 

 

Snap drill to pad：将钻孔与焊盘对中。 

 

Scale：比例。用于设置层的缩放比例。 

 

2. Change（更改）：在这里可重新设定每个元素的 D 码，字体的大小、样式，坐标的原点等。 

 

Dcode：更改 D 码。 

 

Text：文字。 

 

Text Style and Contents：文字风格和内容。 

 

Explode：打散命令。如字符可打散为线，客户自定义光圈及铜皮均可打散成线。 

 

All：打散所有。 

 

Custom ：打散自定义 D 码。 

 

Vector Polygon：打散矢量多边形。 

 

Text：打散文字。 

 

Sectorize：圆弧转折线。 
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Origin：设置坐标原点。 

 

Space Origin：绝对原点。 

 

Grid Origin：网格原点。 

 

Datum Coordinate：数据坐标。 

 

Panelization Anchor：排版原点。 

 

3. Trim using（修剪）：这个操作只对当前有效的线元素有作用，常用于调整一些线段，如修剪等。 

 

操作时要先选择修剪的分界线，左键选择，可以连续选择成多顶点窗口状。右键确定，再左键点选需要修剪的 Line。 

注意：圆弧是不能被修剪的，需要修剪时只有先把它转成折线，然后再修剪。 

 

Line：通过一条线作为修剪线的部分。 

 

Circle/arc：通过圆或弧来作为修剪边界的部分。 

 

4. Line change 线的更改 

 

Chamfer：倒斜角。 

Fillet：倒圆角。 

Join segments：可合并多段线条。 

Break at Vtx：在顶点处打断。 

Segments To Arcs：折线转圆弧。 

 

5. Move vtx/seg：移动顶点/分节 

 

6. Add vertex：增加顶点 

 

7. Delete vertex：删除顶点 

 

8. Delete segment：删除分节 

 
1. Mill Path 铣路径 

 

下面几项功能只对 NC 层的 NC 数据才有效，对 graphic(gerber 层)数据无效，要对 gerber 数据进行编辑是要退到 CAM Editor 界面下。 

 

Chamfer 倒斜角（只对 NC 数据有效） 

 

Fillet 倒圆角（只对 NC 数据有效） 

 

Plunge/Extract 更改下刀点（提刀点） 

 

更改下刀点在做锣带时经常用到的，需要注意的是在更改下刀点后，由于 cam350 的捕捉功能的原因，要对下刀点处进行再处理，用

Edit 菜单下Move Vtx（移动顶点）命令更改后的下刀点进行操作时会发现该处多出一个小段出来，用 Delete Set(删除段)命令将其删
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掉。否则，在实际生产过程中会在下刀处出现一个缺口。 

 

Add Atx at Intersection 在交叉处添加一格顶点这是一项比较实用的功能，使用它在处理锣带制作过程中，无法连续走刀，而需要提刀

的时候快速有效的找到两次走刀的共同点。 

 

在生产（gerber to mill）锣带过程中经常会碰刀这种情况：当弧度适当时是可以连续走刀。当出现圆弧变形就需要按下面的操作步骤

来对它进行处理了。 

 

先选 Utility 里的 Offset Mill Path(路径偏移)命令，将已经打好补偿的路径定义为 g40 属性。接着用 Add Atx at Intersection 命令鼠标左

击两条圆弧的交叉处（是 NC 层上）会发现在交叉处多出一个顶点，再用 Delete Seg(删除段)命令将不需要的段咔嚓掉。准确、快捷，

接刀处天衣无缝，这一招很有用。 

 

Segments To Arc 折线转圆弧（只对 NC 数据有效） 

 

2. Path Properties 路径属性（补偿方向） 

 

3. Path Direction 路径方向（走刀方向） 

 

4. Drill Hit 更改钻数据的孔径 

 

5. Mill Tab 更改 Tab 位 

 

6. Drill Order 钻数据的次序 

 

7. Drill First/Last 定义首、尾孔 

 

8. Mill Order 铣数据次序 

 

9. Compensation 定义补偿 

 

10. Tool 更改刀具 

 

11. Explode 打散 

 

CAD 文件转换成 Gerber文件及 D码表 
 
关于各种 CAD 软件转换成 Gerber 文件的详细过程请参阅相关的软件操作说明，这里只是根据我们的经验提出一
些在转换中应注意的问题。 
 
（一）、Protel for DOS 转 Gerber 时应注意的问题 
1、D 码匹配的上下限不要设得太宽，这样容易造成偏差太大，致使最小间距无法保证。 
2、有时填充区（Fill）转换可能造成错乱。此时应将 D 码表中的方型 D 码全部删除，再重新转换。 
3、在 D 码匹配不上而要求手工匹配时，一定要选方式 3。 
4、在圆弧（arc）转换时，步距（Arc Quality）不要设得太小，否则会造成数据量过大，而且圆弧边缘不光滑。 
5、阻焊扩大值可以是负值。 
6、圆弧转换可以选择圆弧描述还是直线描述。 
Software Arcs: on 为直线描述，转换时用折线近似园弧。 
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Software Arcs: off 为圆弧描述，真正的园弧描述方式。 
对于能够接受圆弧描述的光绘机最好采用圆弧描述。这样做 Gerber 文件数据量小，光绘圆弧边缘光滑。 
7、当所用 D 码超过 24 个时，应将 G54 选项打开。 
8、当单面焊盘需要打孔时，要将 Options\Single layer Pad Holes 项目打开。 
9、有些工具软件可以由MAT 文件产生完全配置的 D 码表。 
 
（二）、Protel for Windows 转 Gerber 时应注意的问题。 
1、用 PFW 可根据 PCB 文件自动生成 D 码表。但该 D 码表中的 D 码可能多达数百个，此时应清楚知道你的光
绘系统 D 码的容量是多少。 
2、如果采用的 D 码表不是由 PFW 自动生成的，以下情况可能导致错误： 
①在 PFW 中可能有大小为 0 的焊盘或线条； 
②有 Relief 型的焊盘时； 
③D 码不配置时。 
在以上情况下在MAT 文件中会出现很大的 D 码。 
3、PFW 中有长八角型焊盘，在转换时 D 码表中不应有此种 D 码。因为在现行的多数光绘系统中都不接受这种定
义，出现这种 D 码会导致错误。遇到这种情况时应采用填充方式匹配这种 D 码。 
4、最好采用用户自定义的 D 码表，而不要用 PFW 自动生成的 D 码表。 
 
（三）PADS 转 Gerber 时应注意的问题。 
1、PADS 预设的 D 码表中的 D 码容量太小，需要扩充其容量。 
2、有的 PADS 文件需要进行铜皮填充后在转换。 
3、由于 PADS 软件设计线路的特殊性，需要注意观察每图形中要选取哪些元素，避免出现失误造成转出图形错误。 
 
（四）PowerPCB 转 Gerber 时应注意的问题。 
1、有的 PowerPCB 文件需要进行铜皮填充后在转换。 
2、PowerPCB 是 PADS 的 Windows 版本软件，因此在文件的转换中基本与 PADS 相同，同样的问题也是需要注
意观察每图形中要选取哪些元素，避免出现失误造成转出图形错误。 

CAM350 NC 编辑器其它菜单---CAM 制作实用经验技巧 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:02 
 
1.当客户未提供钻孔文件时，除了可以用孔径孔位转成钻孔外，还可以用线路 PAD 转成钻孔文件。当孔径孔位符
号之间相交不易做成 Flash 时，或未给出孔数时（一般指导通孔），用以上方法比较好。先将线路上的所有 PAD 拷
贝到一个空层，按孔径大小做 Flash 后将多余的贴件 PAD 删除后转成钻孔文件即可。 
 
2. 当防焊与线路 PAD 匹配大部分不符合制程能力时，可将所有线路 PAD 拷贝到一个空层，用此层和防焊层计较
多余的线路 PAD 删除，接着将此层整体放大 0.2mm（整体放大或缩小：Utilities-->Over/Under），最后将防焊层的
吃锡条或块（大铜皮上的）拷贝过去即可。用此方法做防焊一定要与原始防焊仔细比较，以防多防焊或少防焊。 
 
3.当资料有大面积铜箔覆盖，线路或 PAD 与铜皮的距离不在制作要求之内，且外型尺寸又较大时，（如广上的）可
用下列方法快速修整线路或 PAD 与铜皮的间距。先将线路层（此层为第一层）的所有 PAD 拷贝到一个空层，把
对应在大铜皮上的 
PAD 删除后将剩余 PAD 放大做为减线路层（即第二层），然后把第一层拷贝到一个空层，将大铜皮删除后作为第
三等。合层方式为：第一层（加层）、第二层（减层）、第三层（加层）。一般来说我们为了减小数据量，可以将第

一层只保留大 
铜皮。如果只是防焊到大铜皮的间距不够，就可以把放大后（满足制程能力）的防焊拷贝到一个空层，把对应在大

铜皮上的防焊删除后将剩余防焊放大做为第二层。 
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注：用此方法做好线路后，一定要用命令将多个层面合成 Utilities-->Convert Composite 的一个复合层转换成一个层
面，然后将此层和原稿用 Anglysis-->Compare Layers 命令进行仔细核对。 
 
4.有些资料的文字层有很多文字框，且文字框到线路 PAD 间距不满足制程能力时，可借鉴以下方法：先将任何类
型的以个文字框用 Edit-->Move Vtx/Seg 命令拉伸至规格范围后做成 Flash,接着将其同类型的其它文字框做成与之
相同的 Flash 即可。但要注意的是，做成 Flash 后一定要将其打散，以防下此打开资料时 D 码会旋转。 

制作锣带的基本步骤 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:19 
 
一、根据MI 要求检查 outline 的尺寸及孔刀边数据，内角 R 值要求，画好成品 Outline。 
 
二、分好层，一般习惯性的保留原装 outline 和原装钻带，套板 outline 和生产钻带，以及要生成的 rout 层，delete 
那些与做锣带无关数据。 
 
三、设定 NC Tool Table，用MI 指定的定位孔，根据内槽大小，拼片间距以及内角的 R 值要求来选用刀具，着里
需要注意的是要到 NC Editor 的界面下。 
 
四、用 NC 界面下 Utilities 菜单选 Gerber to mill,直接生成锣带，在转换的过程中注意走刀方向和是否补偿。用 Edit 
菜单下的 Copy 命令把生产钻带的定位孔（即根据MI 要求在刀具表里已经设定好的）Copy To Layers(目的层就是
rout层)。需要注意的是在加定位孔时要尽量能防反，以免铣边操作员上反板。 
 
五、退出 NC 界面到 CAM 界面，到 Utilities 菜单选 Draw To One-Up Border(定 Border,就时选成品外围)，到 Panlel 
Editor 界面下，点窗口上方的 Setup,将 advanced 选项打勾，在按 OK。再点 create 键，将 spreadsheet 切换成
AutoCalc(左击鼠标，选 yes 即可)，选 delete inage 将那些不是按你的意愿拼片的 Border删除，只保留第一个，将
表格里的数据都改为 O，按 OK。到 Edit 菜单里用 Copy 命令将片拼好，就可以输出锣带了，保存资料，退出 Panlel 
Editor 界面。 

CAM 350筛选编辑器 

来源:网上收集   作者:未知   日期:2005-11-19 10:51:18 
 
筛选编辑器（点 filter）： 
 
1. Dcodes 用来筛选 D 码。 
 
空格表示所有都有效，只要层的状态是打开都可以被编辑。 
 
键入 10，表示只有 10 号 D 码才能被选中编辑，其他的 D 码就被筛选掉了。 
 
键入-10，表示除了 10 号 D 码以外都可以被选中，10 号 D 码就被筛选掉了。 
 
键入 10：20，表示从 10 号 D 码到 20 号 D 码都处于激活状态。 
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键入-10：20，表示从 10 号 D 码到 20 号 D 码都被筛选掉了。 
 
2. Tool References 用来筛选刀具。 
 
3. Tab Ids 用来筛选 Tab 位（即连接位，锣带里才用的到）。  

CAM 350一些基本操作 

来源:网上收集   作者:未知   日期:2005-11-19 10:51:15 
 
Gerber to NC Mill： 
 
Source Layer 源层(套 outline 层) 
 
Target Layer 目的层 
 
Tool Table 与目的层相对应的刀具表 
 
Dcodes D 码筛选 
 
Remove Redundant Data 忽略重线 
 
NC Tool Table：  
 
Tool Table 刀具表（不同的刀具表可通过它来切换） 
 
Display Order 显示次序（有按刀具序号、尺寸和输出顺序等三种方式，且分升序和降序两种模式） 
 
Delete Tool 删除刀具（相对应的孔将全部被删除） 
 
Renumber Tools 刀具重排序 
 
Combine Tools 合并刀具 
 
Report NC Tool NC 刀具数据报告（孔数、锣程都在这里） 
 
Table Name/Type 表格名称和类型 
 
New Table 新建刀具表 
 
Export Order 输出刀具次序  
 
Tab 位的使用：  
 
Mill Tool Size 锣刀尺寸 
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Tab Size Tab 位大小 
 
Name Tab 位名称 
 
要注意的几点： 
 
1.要先 add tab,否则无法定义数据。 
 
2.mill tool size 就是锣刀尺寸，如果填错会导致 tab size 错误，tab size等于连接位尺寸（中心到中心，而非边到
边，如连接位的槽的中心到中心 3mm，槽宽 2mm,则边到边为 1mm，如果槽宽 2.4mm，边到边就是 1.6mm 了）
减去锣刀尺寸，当连接位为 3mm，槽宽 2mm 时用 2.0mm 的锣刀 tab 位尺寸就是 1mm，槽宽为 2.4 时 tab 位
还是 1.0mm，但还要配合其它的动作才能使边到边达到 0.6mm 的效果。 
 
Gerber to NC Drill：  
 
Source Layer 源层（选择你想转为钻孔的那一层） 
 
Target Layer 目的层（转换后的钻孔所在层，不需改变） 
 
Tool Table 与目的层相对应的刀具表（一般不需改变） 
 
Dcodes D 码筛选 
 
0 或空白 = 全选 
 
#，#，…… 包含 
 
#：#，…… 范围 
 
-#，-#：#，…… 不包含 
 
Remove Redundant Data 删除重叠的孔 
 
Drill Type 选择钻孔层为 PTH 或 NPTHAutoCAD 与 CAM350 之间的转换唯一可靠的媒体是：DXF File，但记住，
CAM350 

只支持 AutoCAD R14，且 CAM350 V7.0 的 DXF Interface 有重大 bug，用 V6.0比较安全。 

CAM350 V8.0 用户界面介绍 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:13 
 
1. Main Menu Bar:主菜单栏，直接单击鼠标左键即可打开个菜单，也可通过 ALT与菜单项首字母的组合打开菜单。 
 
2. Tool Bar:工具条，这个动态的工具条包含好几项功能。栅格选择框是固定的，而其他的如 Active Dcode、Active 
Layer 可以根据具体的命令而改变。 
 
3. Grid Selection:这是一格组合框，既可以从下拉列表中选择栅格大小，也可以直接输入栅格尺寸。输入的 X、Y 坐
标值可以是整数也可以是小数，而且可以是不同的值。如果输入了 X 坐标然后回车，那么 Y 坐标就默认为与 X 坐
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标相同。 
 
4. Active Dcode:这是一个当前定义的光圈（Aperture）的下拉列表；在列表中被选中的选项将设置为当前激活的 D 
码。与热键“D”具有相同功能。 
 
5. Active Layer:这个下拉列表包含板子的所有层，单击任何一层将激活该层，并使该层为当前层。与热键“L”具
有相同功能。 
 
6. Layer Control Bar:这个垂直的工具条位于窗口的左侧，用来控制所有层的信息。控制条的上方为 Redraw、Add 
Layer、All On、All Off 按钮。其中 Redraw 是刷新显示，与热键“R”有相同功能。Add layer 可以在现有的层后
面再加一层，同样也可以利用菜单中 Edit -> Layers -> Add Layers 命令来实现增加层的操作。All On 按钮将所有层
都再主工作区域内显示出来。All Off 将除当前层之外的所有层都关闭。 
 
鼠标左键点击任意层的数字就可以将该层设置为当前被激活的层，并且会在该层的数字上显示一个蓝色的小框。如

果右键点击任意层的数字，那么这一层将成为最前面的一层。并且在这层的数字上会有一个透明的小框显示。 
 
在代表层的数字右侧是层的颜色，这个颜色分两个部分：左边是 draw 颜色，右边是 flash 的颜色。右击就可以改
变 draw/flash 的颜色，这时就会打开调色板：可以在调色板上选择 Show/Hide 来显示或隐藏 Draw 和 Flash，还可
以点击 Load 来导入另一个调色板。 
 
7. Status Bar:状态栏，在屏幕的最下方。提供了有关当前命令、光标所在位置的坐标、单位等信息。 
 
显示当前光标位置或设置光标位置模式：显示光标所在位置的坐标，并且可以精确到小数点后四位。也可以用来直

接是输入新的坐标，这其实相当于用鼠标左键在工作区内点击所显示的坐标。要想输入坐标时，只须双击就会出现

一个对话框。此时，对话框中显示的位鼠标左键上次点击的坐标值。可以输入新的坐标，利用回车键切换 X、Y 坐
标的输入。另外，对话框中还右三种模式可供选择：Absolute/Relative/AutoPan 。 
 
Absolute 是绝对坐标模式，这种模式下显示的是实际的坐标值。 
 
Relative 模式是相对坐标模式，这种模式下显示的是当前坐标相对于前一坐标的变化值。此时，屏幕上会出现一个
小的圈记录光标前一次所在的位置。在输入坐标时，如果以@符号开头，系统将默认选择进入 Relative 模式。 
 
如果选择 AutoPan 的话，系统自动显示输入点，包括不在当前显示范围内的点。 
 
8. 右边是单位显示，这个单位与 Settings -> Unit 中的设置是一致的。 
 

CAM350 中资料的读入 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:13 
 
在 CAM350 中，读入 Gerber 文件的方法有两种： 
 
分别为：自动导入和手动导入。 
 
我们多数用自动导入（因为在 CAM350 中普遍的 D 码其都能自动识别）。而手工导入时操作比较麻烦，主要是在
软件不能自动识别其 D 码时使用。 
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自动导入（AutoImport）： 
 
1.操作前必须把所以的 Gerber 文件存放在同一个目录中，同时不能有其他文件在这一文件夹中。 
 
首先：自动读入一个 Gerber 文件，操作：File -> Import -> AutoImport 
 
2.选择文件所在目录，接着选择单位：English（英制）、Metric（公制），一般为英制。然后按下 Next 进行 Gerber 文
件的读入（注：若你的 D 码非 RS-274-X 格式时，请不要选择 Finsh）。 
 
3.在出现的对话框中将会列出文件的 D 码和光栅格式。此时进行正确的设置，按下 Finsh 完成。 
 
单位一定要选择 English（英制）。对于*.art 文件，可以选择“Apply to All"将设置延伸到其他 Gerber 文件。对于
Aperture 文件的类型，如果是 Rs-274-D要选择“Aperture”,如果是 RS-274-X，则选择“RS-274-X no Aperture”. 
 
4.按下 Finish 完成后，若出现“Tool Numbers with No;1,2,3,……，则表示钻孔的 D 码数据并没有正确输入。这时
你可直接按”确定“结束，这并不会有什么影响。 
 
5.如果读入的最后结果有不合理的断、短路或外型尺寸不正确，则表示你读入的 Aperture Format 数位或格式有错。
这时你就要调整读入时所选的单位格式，直到读到为止（多数 PADS 格式都是英制 2：3 或公制 2：4）。 
 
在 Aperture Format 列表中为可自动识别的 D 码格式，Gerber Format 为设置当前的底片文件的数据格式类型。 
 
6.正确设置好格式后，就可以正确读入 Gerber 文件了。能否正确读入 Gerber文件，关键为对 Aperture Format 的设
置。 
 
注：有时钻孔文件不能自动导入，这时点击 File 菜单中 Import -> Drill Data 的，接着选择文件所在的路径、单位
和格式即可。 
 
手动输入： 
 
a) 标准的 gerber file 格式可分为 RS-274 与 RS-274X 两种，其不同在于：RS-274 格式的 gerber file 与 aperture 是
分开的不同文件。 
 
RS-274X 格式的 aperture 是整合在 gerber file 中的，因此不需要 aperture文件(即，内含 D 码)。 
File -> Import -> Gerber Data 
 
单击 layer 1，输入 GERBER 文件，按下 Data Format 进行设置。 
 
选择文件格式、绝对坐标还是相对坐标、前导零还是后导零。 
 
“绝对坐标” 和“相对坐标” 
 
绝对坐标：即其坐标以 0 坐标为原点，是一个绝对的值。是一个正值。 
 
相对坐标：看其正负，相对坐标总是有正负的，当前坐标总是依照前一坐标递增或递减。 
 
前导零、后导零和不导零： 
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例：025690 前导零后变为：25690 (Leading) 
025690 后导零后变为：02569 (Trailing) 
025690 不导零后变为：025690 (None) 
 
Gerber file 的格式： 
 
通常，英制是 2：4 格式 
公制是 3：3 格式 
 
单位： 
 
数据格式：整数位+小数位，常用： 
2：3（英制，整数 2 位，小数 3 位） 
2：4（英制，整数 2 位，小数 4 位） 
3：3（英制，整数 3 位，小数 3 位） 
 
RS-274-D 格式的 Gerber 还要设置 Aperture 文件，点击 OK 后就变成可以设置 Aperture 文件的对话框，点击
“Aperture File"按钮则弹出一个“Aperture"对话框：和自动导入一样，选择 Others 然后根据不同的 EDA 软件选择
Aperture的格式，然后由“Aperture File"找到该文件的目录，OK 以后即可导入各层数据。 
 
为了读对 RS-274 格式的 gerber file，你需要有如下概念：RS-274 格式的 gerber file 必须同其对应的 aperture 文件
配合才能正确输入。 
 
CAM350 的 AutoImport 功能读 RS-274 格式的 gerber file 是能自动辨认 aperture 的格式的（不同的 CAD 软体产
生的 aperture 的格式也是不同的），而 CAM350 的这一功能又是靠其安装目录中.arl 为模板来实现的。 
 
当我们用 CAM350 不能正确读入 RS-274 格式的 gerber file 时，通常是因为不能正确辨认 aperture 而造成的，这
就需要编写自己的.arl 文件来协助 CAM350 正确读入 gerber file。 
 
注：能否正确读入 GERBER 文件，关键为对 Aperture Format 的设置。 
 

CAM350猜格式技巧 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:13 
 
如果客户给你的文件不是 RS-274-X 格式，而且你的客户也不知道数据格式！ 
 
那么下面告诉你一些猜格式的技巧。 
 
方法一：穷举法 
 
如：X535489Y416899D03* 
 
是六位数的,不是 2.4 就是 3.3，总之加起来是 6 即可。或在M:N 组合中用”穷举法”进行调用(即 2:3、2:4、…逐
个试)。 
 
方法二：根据板面大小 
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硬质板中很少有板面尺寸大于 20Inch 的，而大于 20Inch X 20Inch 的是没有的。据此，如果您读出来的图形大于
20Inch，那就是小数点前的位数太多了。相反，如果您读出俩的图形都堆到原点附近，那十有八九是小数点后的位
数太多 
了（也就是说，小数点前的位数太少了）。 
 
这里需要注意的是，小数点前的位数加上小数点后的位数一定要等于 Gerber 文件中最长的数的位数。 
 
方法三：根据已知尺寸 
 
如果您知道一些关于板子的尺寸，那就好办多了。您只要不停的试，大了就把小数点前的位数变小（小数点后的位

数同时变大）；小了就把小数点后的位数变小（小数点前的位数同时变大），如果单位没有搞错，一两次就能正确了。

如果您没有任何尺寸，那您只能找板子上的器件。有一些器件，如 DIP（双列直插集成电路）、PGA 封装和一些插
座，它们引脚的中心距离是 0.1Inch(2.54mm),根据这一点您也能大概地确定数据格式 
 

CAM350 读入文件出错分析 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:12 
 
文件的扩展名不同，只是输出底片文件的 CAD 软件不同罢了，其实质是一样的，都是 Gerber File。 
 
可能造成我们输入错误的因素有： 
 
a) 输入 gerber file 时的单位选错 (Metric or English)。 
b) 如果 gerber file 是 RS-274 格式的，读错其配套的 aperture 文件 （最可能）。 
c) 软件本身的 bug 
 
下面，就对 a 和 b 进行说明： 
 
a) 一般来说，gerber file 都是英制的，因为大多数 CAD 软件为西方国家的产品。 
 
如果使用 CAM350 的 AutoImport 功能输入 RS-274X 格式的 gerber file，操作如下： 
 
1. 选择 File -> Import -> AutoImport 选项。 
 
2. 在对话框中，选择 gerber file 放置的文件夹，点选 gerber file 是公制还是英制（English or Metric），按 Finish 完
成。 
 
3. 需要注意，要输入的所有 gerber file 必须放在同一文件夹中，不能同时有不相关文件在这一文件夹中，才能正
确读取这一文件夹中的 gerber file。 
 
b) 标准的 gerber file 格式可分为 RS-274 与 RS-274X 两种，其不同在于： 
 
RS-274 格式的 gerber file 与 aperture 是分开的不同文件。 
 
RS-274X 格式的 aperture 是整合在 gerber file 中的，因此不需要 aperture文件。 
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(Gerber file 的格式：通常，英制是 2.4 格式，公制是 3.3 格式)为了读对 RS-274 格式的 gerber file，你需要有如下
概念：RS-274 格式的 gerber file 必须同其对应的 aperture 文件配合才能正确输入。 
 
CAM350 的 AutoImport 功能读 RS-274 格式的 gerber file 是能自动辨认 aperture 的格式的（不同的 CAD 软件产
生的 aperture 的格式也是不同的），而 CAM350 的这一功能又是靠其安装目录中.arl 为模板来实现的。 
 
当我们用 CAM350 不能正确读入 RS-274 格式的 gerber file 时，通常是因为不能正确辨认 aperture 而造成的，这
就需要编写自己的.arl 文件来协助 CAM350正确读入 gerber file。 
 
辨认 aperture 读入正确与否的方法： 
 
看 aperture table 是否均已正确读入，不存在 undefined aperture。如果线路层（copper layer）中有 QFP 的话，看其
方向是否对。这种情况通常是 rectangle 的 aperture 被读反而造成的（X, Y 读颠倒）。 
 
其它明显的不正常现象，如：线端无 pad、不合理断、短路等。 
 
当你读入 RS-274 格式 gerber file 发现外形尺寸正确，而线路、pad 明显偏小或偏大，这通常是 CAM350 的.arl 文
件单位设置与读入的 aperture 单位不符造成的。正确读入做法如下： 
 
使用 AutoImport 功能，点击 Next 与 Scan each Gerber 选项。 
 
在出现的对话框中，察看 CAM350 读入时所用的.arl 模板名是什么。 
 
找到此.arl 文件，修改其单位，另存为改名的.arl 文件。 
 
*.arl 文件的文件名通常与.arl 模板名类似，上例的.arl 文件的文件名为：pcad8.arl（CAM350 自带的标准.arl 文件）。 
 
如果线宽、pad 大小正确，而外形明显偏大时，会看起来线路过于稀疏，这是因为 gerber file 的单位选错（公制
选成英制）。 

CAM350 基本操作 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:12 
 
光标移动（Cursor Movement）: 
 
光标的位置大多数情况下是有鼠标控制的，同样键盘上的上下左右箭头也可以控制屏幕上光标安装一个象素或格点

来移动。水平移动由左右箭头键控制，而垂直方向的移动则由上下箭头键控制。 
 
循环选择（Cycle Picking）: 
 
在任意一个功能选择模式下如Move 或 Copy，可以重复选择编辑对象，这样在执行具体命令前可以选择多个对象，
然后所有被选中的对象将作为一个整体在一个框内，然后一起进行编辑。 
 
几种选择方式（Making Selections）： 
 
在使用一个编辑命令时，如Move，可以选择单个对象，也可以同时选择多个对象。单击鼠标左键即可选择单个对
象，此时被选中的对象跟随光标移动，并且命令提示行显示“[Move:Single]”：选择多个对象时，只要再同时按下
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Ctrl键，此时的命令提示行则显示“[Move:Multiple]”，选择完毕后所有被选中的对象被高亮，光标则变成一个包含
所有被选中对象的框，如果想去调框中的任意对象只要按住 Ctrl 的同时再点击该对象即可，确定好要移动的对象
后就可以移动光标到理想的位置。 
 
取消命令（Abort Commands）： 
 
在一个命令执行过程中可以通过单击鼠标右键或按下热键“Esc”终止命令。 
 
CAM350 支持的 D 码形状： 
 
Round： 圆形 
 
Square： 正方形 
 
Rectangle： 矩形 
 
Target： 靶标 
 
Thermal： 花孔 
 
Custom： 自定义 D 码 
 
Donut： 环形 
 
Octagon： 八边形（不能旋转） 
 
Oblong： 长椭圆形 
 
Triangle： 三角形 
 
Hexagon： 六角形 
 
Ellipse： 椭圆形 
 
Diamond： 菱形 
 

CAM350层的编辑 
来源:网上收集   作者:未知   日期:2005-11-19 10:51:12 
 
CAM350 中对层的编辑功能基本包括增加/删除层、更改各层顺序、设置层的状态和参数、层组合等。 
 
1.增加层：增加层有两种方法。利用菜单项 Edit -> Layers -> Add Layers,或者在左边工具条点击快捷图标，在出现
“Number of new layers”后输入需要增加的层数。 
 
2.删除层：Edit -> Layers ->Remove Layers,选择要删除的层。 
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3.更改各层顺序：有时为了看起来方便想按一定顺序排列各层，可以通过菜单项 Edit -> Layers -> Reorder Layers 来
实现更改各层顺序的功能。调整顺序时先选中要调节顺序的层，然后移动鼠标到理想的插入点即可，最后按下

Renumber 
排序。 
 
4.设置层的状态和参数：查看、更改各层信息可以按下热键“Y”或利用菜单项 Tables -> Layers,层信息包括层的名
字、层的类型、Flash/Draw 颜色、层的状态（On/Off/Ref）、是否当前被激活的层、是否在最前面一层。 
 
5.层的组合：在看 Gerber 时经常会需要同时打开某几层一起看，这时，利用某个热键一下子打开几层就会显的非
常便捷。CAM350 中“层组合设置功能”就能很好的做到有目的将几层并为一组简单的使用一个热键就能同时打
开这组内所 
有的层。在 CAM350 中有四种不同的层组合选择分别为：User/Layer Stackup/Blind and Buried/MCM Technology。
其中，User 为通用的用户定义类型；Layer Stackup 是在拼版过程中使用的层组合设置：Blind and Buried 是配合
Netlist 的产生使用的；MCM Technology 是专门针对MCM 技术的基板的 Gerber文件。这四种形式下的层组合设
置功能可以通过 Tables -> Layer Sets 菜单下的四个选择来实现。 
 
由于 Layer Stackup/MCM Technology 和我们关系不大，这里仅介绍 User和 Blind and Buried 两种方式。关于打开
组合层的热键，CAM350 是这样规定的，系统默认的热键为数字键 0-9，从 1 开始为第一个层组合设置，依次类
推，0 则代表第 10 个层组合设置：当然 CAM350 可设置 10 个以上的层组合，但只有前 10个可以通过热键打开。 
 
首先介绍 User 类型：打开 Tables -> Layer Sets -> User 菜单会出现“User Layer Sets”对话框： 
 
在左边的"Layer Sets"列表中是层设置的名称及其分配的热键数字。名称是在右边的“name”框中输入的。名字可
以使用默认的，也可以自己定义，但是命名中不允许包含空格。一般在“Layer Sets"列表中显示的是“LS1：
LyrSet_1<..Hot Key 1",但如果在其他三中类型（Layer Stackup/Blind and Buried/MCM Technology)中已有过设置，则
将自动以下一个未使用的热键开始。 
 
如是以“LS1：LyrSet_1<..Hot Key 1"开始的，则表面热键 1 已经使用过。接下来依次点击右边数字按钮来加入每
个 Layer Sets 中包含的层。如点击 1 按钮就会弹出“Layer List”的选择框，OK 后该层就显示在 1 按钮右侧的框
中，点击 2 按钮加入另一层，重复这个过程直到所有的期望的层都被加入。如果还要在编辑一个层组合只要点击
Add 按钮然后重复刚才的操作即可。当然，点击某个 Layer Sets 按下 Delete就可以删除该设置，也可以选择组内
的各层。所有这些设置将被保存在*.CAM 文件中以备下次使用。 
 
接着介绍 Blind and Buried 类型：这个功能只有当 Gerber 文件中含有盲孔、埋孔信息时才有效。由于这个功能时
配合 Netlist 的提取而设置的，必须在提取 Netlist 之前先设置层，只要先告诉系统 Blind and Buried 在哪个层组合，
才能提取正确的 Netlist。具体实现过程与 User 类型类似，打开 Tables ->Layer Sets -> Blind and Buried 菜单项，出
现“Layer Sets For Blind and Buried Via"对话框： 
 
Layer Sets 的命名及层的加入都和前面讲的一样，只是还要调入两个钻孔文件。点击“Thru Drill”按纽并选择通孔
钻孔文件，再点击“Drill Data”选择相应的文件。当“Blind and Buried”类型的层组合设置成功后，在“Layer Table”
对话框下方的“By Layer Set”按钮才会生效。 
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